HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem E. Travel

Problem E Travel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 138    Accepted Submission(s): 66


Problem Description
It is said Guilin's scenery is the best in the world. Now since the first Guangxi Province Collegiate Programming Contest is held in Guilin, Luras decided to travel around Guilin. She knows that there will be n nodes in the travel map. Luras will pick a shortest way to go from node 1 to node n. You are a city designer who could decide if there is a bi-directional edge with the length of 1 between every two nodes. And you hope to build the roads to make the shortest path from 1 to n to be as many as possible. Could you tell Luras how many shortest path could it be at most between node 1 and node n in your final city graph?
 

Input
The first line is an integer T which indicates the case number.
And as for each case,  there will be one lines
In the line, there is 1 integer n, which indicates the number of node.
It is guaranteed that——
T is about 100.
for 100% cases, 2 <= n <= 40.
 

Output
As for each case, you need to output a single line.
There should be one integer in the line which means the maximum shortest path could be between node 1 and node n.
 

Sample Input
6
2
3
4
5
6
7
 

Sample Output
1
1
2
3
4
6


解题思路:点击打开链接


AC 代码

#include<bits/stdc++.h>
#include<cmath>

#define mem(a,b) memset(a,b,sizeof a);
#define INF 0x3f3f3f3f

using namespace std;

typedef long long ll;

int main()
{
    int T; scanf("%d",&T);
    int n;
    while(T-- && ~scanf("%d",&n))
    {
        n-=2;
        int rs;
        if(n==0) rs=1;
        else if(n<4) rs=n;
        else
        {
            int cnt3,cnt2;
            if(n%2==1)
            {
                cnt3=(n-3)/6*2+1;
                cnt2=(n-3)%6/2;
            }
            else
            {
                cnt3=n/6;
                cnt2=n%6/2;
            }
            rs=pow(3,cnt3) * pow(2,cnt2);
        }

        printf("%d\n",rs);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/dream_weave/article/details/81054367
今日推荐