POJ - 2385 Apple Catching

Apple Catching

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14877   Accepted: 7279

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
using namespace std;
int t,move;
int a[1002],dp[1002][40];//dp[i][j] 前i秒移动j次最多吃了多少个苹果 
void solve()
{
	for(int i=1;i<=t;i++)
	{
		for(int j=0;j<=move;j++)
		{
			if(j==0)//不移动 
                dp[i][j]=dp[i-1][j];//不移动 位置不变 苹果数量继承上一秒的 
            else//移动 . 到第i-1分钟时,在1和 2下得到苹果的最大值 
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]);
            if(j%2+1==a[i])//j%2+1代表 移动到哪棵树下 
                dp[i][j]++;//苹果++ 
		}
	}
}
int main()
{
	cin>>t>>move; 
	for(int i=1;i<=t;i++)
	{
		cin>>a[i];
	}
	memset(dp,0,sizeof(dp));
	solve();
	int maxx=-99999;
	//最后时间 看移动到哪棵树下苹果最多 
	for(int i=0;i<=move;i++)
	{
		maxx=max(dp[t][i],maxx);
	}
	cout<<maxx<<endl;
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81074978