STL——Windows Message Queue

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

优先队列,不过要根据优先级进行排序,我这里标记了一个输入顺序,当rank不一样时根据rank来比较,rank相同时则直接根据输入的次序比较。

hdu上可以用cin,cout,不过大量输出尽量用scanf和printf。

hdu1509  http://acm.hdu.edu.cn/showproblem.php?pid=1509

附代码:

#include <iostream>
#include <stdio.h>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
struct Message
{
    char mes[300];
    int key;
    int rk;
    int t;
    friend bool operator <(Message x,Message y){
        if(x.rk!=y.rk)
            return x.rk>y.rk;
        return x.t>y.t;
    }
};
priority_queue<Message> Q;

int main()
{
    char c[4];
    int k=1;
    while(~scanf("%s",c)){
        if(c[0]=='P'){
            Message p;
            scanf("%s%d%d",p.mes,&p.key,&p.rk);
            p.t=k;
            k++;
            Q.push(p);
        }
        else{
            if(Q.empty())
                printf("EMPTY QUEUE!\n");
            else{
                Message p=Q.top();
                Q.pop();
                printf("%s %d\n",p.mes,p.key);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/suqia/article/details/81081564
今日推荐