谁是作案嫌疑人?


谁是作案嫌疑人?

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

刑侦大队对涉及六个嫌疑人的一桩疑案进行分析:一、a ,b至少有一人作案;二、a,e,f三人中至少有两人参与作案;三、 a ,d不可能是同案犯;四、b,c或同时作案,或与本案无关;五 c,d中有且只有一人作案;六 如果d没有参与作案则e也不可能参与作案。试编写程序,寻找作案人。

Input

多组测试数据,对于每组测试数据,第 1 行输入 6 个空格分隔的整数,代表a、b、c 、d 、e 、f的编号,编号x范围(1 <= x <= 6),且编号互不相同。

Output

对于每组测试数据,第 1 行至第 6 行分别输出对 a、b、c 、d 、e 、f的判断,详细输出格式请参考样例。 

Sample Input

1 2 3 4 5 6

Sample Output

The suspects numbered 1 are criminals.
The suspects numbered 2 are criminals.
The suspects numbered 3 are criminals.
The suspect numbered 4 is not a criminal.
The suspect numbered 5 is not a criminal.
The suspects numbered 6 are criminals.

Hint

Source



#include <iostream>
#include<bits/stdc++.h>
using namespace std;

int main()
{
int a,b,c,d,e,f;
while(scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f)!=EOF)
{
    printf("The suspects numbered %d are criminals.\n",a);
      printf("The suspects numbered %d are criminals.\n",b);
        printf("The suspects numbered %d are criminals.\n",c);
          printf("The suspect numbered %d is not a criminal.\n",d);
            printf("The suspect numbered %d is not a criminal.\n",e);
              printf("The suspects numbered %d are criminals.\n",f);

}
    return 0;
}

谁是作案嫌疑人?

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

刑侦大队对涉及六个嫌疑人的一桩疑案进行分析:
一、a ,b至少有一人作案;
二、a,e,f三人中至少有两人参与作案;
三、 a ,d不可能是同案犯;
四、b,c或同时作案,或与本案无关;
五 c,d中有且只有一人作案;
六 如果d没有参与作案则e也不可能参与作案。
试编写程序,寻找作案人。

Input

多组测试数据,对于每组测试数据,第 1 行输入 6 个空格分隔的整数,代表a、b、c 、d 、e 、f的编号,编号x范围(1 <= x <= 6),且编号互不相同。

Output

对于每组测试数据,第 1 行至第 6 行分别输出对 a、b、c 、d 、e 、f的判断,详细输出格式请参考样例。
 

Sample Input

1 2 3 4 5 6

Sample Output

The suspects numbered 1 are criminals.
The suspects numbered 2 are criminals.
The suspects numbered 3 are criminals.
The suspect numbered 4 is not a criminal.
The suspect numbered 5 is not a criminal.
The suspects numbered 6 are criminals.

Hint

Source


猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/80501093