F - Linearization of the kernel functions in SVM HDU - 5095(模拟)

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.

Input

The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.

Output

For each input function, print its correspondent linear function with 9 variables in conventional way on one line.

Sample Input

2
0 46 3 4 -5 -22 -8 -32 24 27
2 31 -5 0 0 12 0 0 -49 12

Sample Output

46q+3r+4u-5v-22w-8x-32y+24z+27
2p+31q-5r+12w-49z+12

题意:将f(x,y,z) = ax^2 + by^2 + cz^2 + dxy + eyz + fzx + gx + hy + iz + j.    注意:下划线部分题目给的试子有点错误

 转化成             g =ap    +  bq   +    cr   +  du +  ev  + fw  + gx +hy  + iz + j

思路:这道题坑有点多~~,交了6发在才过去,都开始怀疑自己是不是看错题了~~

          1.  注意当系数为1时,不显示1,如 p+q+3

          2.  注意当系数为-1时,只显示负号,不显示,如p-q

          3.  当为常数项时,显示数字,如0 ,  -2  ,5

          4.  系数为0的项不显示

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[]="pqruvwxyz";
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int flag=0;
		int x;
		for(int i=0;i<9;i++){
			scanf("%d",&x);
			if(x>0){
				if(flag) printf("+");
				if(x>1)printf("%d",x);
				flag=1;
			}
			else if(x<0){
				if(x==-1) printf("-");
				else printf("%d",x);
				flag=1;
			}
			if(x) printf("%c",str[i]);
		}
		scanf("%d",&x);
		if(!flag) printf("%d",x);
		else if(x>0) printf("+%d",x);
		else if(x<0) printf("%d",x);
		puts("");
	}
	return 0;
}

      

猜你喜欢

转载自blog.csdn.net/islittlehappy/article/details/81071669