Network UVA - 315

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

 

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at mostN lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0.

 

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

 

Sample Input

 

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

 

Sample Output

 

1
2

给出一个无向图,求割点,模板套。

割点: 1,如果u是根节点并且(u,v)是树边,则u是割点

2.如果u不是根节点,若满足dfn[u]<low[v],则u是割点

两种情况满足一种就是割点

#include <cstdio>  
#include <cstdlib>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
using namespace std;  
  
const int N = 110;  
  
struct node  
{  
    int next;  
    int to;  
}edge[N * N];  
  
bool instack[N];  
bool cut[N];  
int head[N];  
int DFN[N];  
int low[N];  
int cnt, tot,_index, root;  
  
void addedge (int from, int to)  
{  
    edge[tot].to = to;  
    edge[tot].next = head[from];  
    head[from] = tot++;  
}  
  
void tarjan (int u, int pre)  
{  
    DFN[u]=low[u]=++_index;
	int cnt=0;
	for(int i=head[u];~i;i=edge[i].next)
	{
		int v=edge[i].to;
		if(v==pre)   //pre是父节点 
		{
			continue;
		}	
		if(DFN[v]==-1)
		{
			tarjan(v,u);
			cnt++;
			low[u]=min(low[u],low[v]);
			if(u!=pre&&low[v]>=DFN[u])   //u不是根节点,并且u,v是树边 
			{
				cut[u]=true;
			}
			if(u==pre&&cnt>1)   //u是根节点,并且有多于一个的子树 
			{
				cut[u]=true;
			}
		}
		else if(low[u]>DFN[v])
		{
			low[u]=min(low[u],DFN[v]);
		}
	} 
	
}  
  
void init ()  
{  
    memset (DFN, -1, sizeof(DFN));  
    memset (low, 0, sizeof(low));  
    memset (instack, 0, sizeof(instack));  
    memset (cut, 0, sizeof(cut));  
    memset (head, -1, sizeof(head));  
    tot = 0;  
    _index = 0;  
}  
  
void solve (int n)  
{  
    root = 1;  
   	for(int i=1;i<=n;i++)
	{
		if(DFN[i]==-1)
		{
			tarjan(i,i);
		}	   	
	} 
    int ans = 0;  
    for (int i = 1; i <= n; ++i)  
    {  
        if (cut[i])  
        {  
            ans++;  
        }  
    }  
    printf("%d\n", ans);  
}  
  
int main()  
{  
	//freopen("C:/input.txt", "r", stdin);
    int n;  
    int u, v;  
    while (~scanf("%d", &n), n)  
    {  
        init();  
        while (scanf("%d", &u), u)  
        {  
            while (getchar() != '\n')  
            {  
                scanf("%d", &v);  
                addedge (u, v);  
                addedge (v, u);  
            }  
        }  
        solve(n);  
    }  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/evildoer_llc/article/details/80304776
315
今日推荐