寒假训练1—H(第一次写出结构体数组)

原题

The Annual National Olympic of Information(NOI) will be held.The province of Shandong hold a Select(which we call SDOI for short) to choose some people to go to the NOI. n(n100) people comes to the Select and there is m(m50) people who can go to the NOI.

According to the tradition and regulation.There were two rounds of the SDOI, they are so called "Round 1" and "Round 2", the full marks of each round is 300.

All the n people take part in Round1 and Round2, now the original mark of every person is known. The rule of SDOI of ranking gets to the "standard mark". For each round there is a highest original mark,let's assume that is x.(it is promised that not all person in one round is 0,in another way,x>0). So for this round,everyone's final mark equals to his/her original mark(300/x).

After we got everyone's final mark in both round.We calculate the Ultimate mark of everyone as 0.3round1s final mark + 0.7round2s

final mark.It is so great that there were no two persons who have the same Ultimate mark.

After we got everyone's Ultimate mark.We choose the persons as followed:

To encourage girls to take part in the Olympic of Information.In each province,there has to be a girl in its teams.

1. If there is no girls take part in SDOI,The boys with the rank of first m enter the team.
2. If there is girls, then the girl who had the highest score(compared with other girls) enter the team,and other(boys and other girls) m-1 people with the highest mark enter the team.

Just now all the examination had been finished.Please write a program, according to the input information of every people(Name, Sex ,The original mark of Round1 and Round2),Output the List of who can enter the team with their Ultimate mark decreasing.
Input There is an integer T(T100) in the first line for the number of testcases and followed T testcases.

For each testcase, there are two integers n and m in the first line (nm), standing for the number of people take part in SDOI and the allowance of the team.Followed with n lines,each line is an information of a person. Name(A string with length less than 20,only contain numbers and English letters),Sex(male or female),the Original mark of Round1 and Round2 (both equal to or less than 300) separated with a space.

Output For each testcase, output "The member list of Shandong team is as follows:" without Quotation marks.

Followed mlines,every line is the name of the team with their Ultimate mark decreasing. Sample Input
2
10 8
dxy male 230 225
davidwang male 218 235
evensgn male 150 175
tpkuangmo female 34 21
guncuye male 5 15
faebdc male 245 250
lavender female 220 216
qmqmqm male 250 245
davidlee male 240 160
dxymeizi female 205 190
2 1
dxy male 300 300
dxymeizi female 0 0
Sample Output
The member list of Shandong team is as follows:
faebdc
qmqmqm
davidwang
dxy
lavender
dxymeizi
davidlee
evensgn
The member list of Shandong team is as follows:
dxymeizi


Hint
For the first testcase: the highest mark of Round1 if 250,so every one's mark times(300/250)=1.2, it's same to Round2.
The Final of The Ultimate score is as followed
faebdc 298.20
qmqmqm 295.80
davidwang 275.88
dxy 271.80
lavender 260.64
dxymeizi 233.40
davidlee 220.80
evensgn 201.00
tpkuangmo 29.88
guncuye 14.40

For the second testcase,There is a girl and the girl with the highest mark dxymeizi enter the team, dxy who with the highest mark,poorly,can not enter the team.
代码:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct peo{
    string name;
    string sex;
    int r1;
    int r2;
    double com;
}a[105];

bool cmp(peo x,peo y)
{
    return y.com<x.com ;
}

//double com[105];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int sum,ok;
        cin>>sum>>ok;
        double r1max=0,r2max=0,femax=0;
        double beir1,beir2;
        string nvmax="0";
        for(int i=0;i<sum;i++)
        {
            cin>>a[i].name >>a[i].sex>>a[i].r1>>a[i].r2;
            if(r1max<a[i].r1) r1max=a[i].r1;
            if(r2max<a[i].r2) r2max=a[i].r2;
        }
        beir1=300/r1max;
        beir2=300/r2max;
        for(int i=0;i<sum;i++)
        {
            a[i].com=a[i].r1*0.3*beir1+a[i].r2*0.7*beir2;
            if(a[i].sex=="female")
            {
        //        cout<<"1";
                if(a[i].com>=femax)
                {
        //            cout<<"2";
                    femax=a[i].com;//femax是女生最高总分
                    nvmax=a[i].name;//nvmax是女生名字
                }
                
            }
            
        }
        sort(a,a+sum,cmp);
        if(nvmax=="0")
        {
            cout<<"The member list of Shandong team is as follows:"<<endl;
            for(int i=0;i<ok;i++)    
                cout<<a[i].name<<endl;
        //        cout<<"1";
                }
        else
        {
            if(a[ok-1].com<femax)
            {
                cout<<"The member list of Shandong team is as follows:"<<endl;
                for(int i=0;i<ok;i++)    
                    cout<<a[i].name<<endl;
        //            cout<<"2";
            }
                
            else
            {
                cout<<"The member list of Shandong team is as follows:"<<endl;
                for(int i=0;i<ok-1;i++)    
                cout<<a[i].name<<endl;
                cout<<nvmax<<endl;
        //        cout<<"3";
                
            }
         }
    
        
    }
 }


猜你喜欢

转载自blog.csdn.net/qq_41660465/article/details/79124529
今日推荐