用 Java 实现大数的运算

 H - Integer Inquiry

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. “This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.” (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

Sample Output

370370367037037036703703703670

用JAVA  实现大数的运算

还没有系统的学过java ,A这道题也是套用的模板

有几点需要注意的:

1、多组输入

     while(cin.hasNext()){

     }

2、判断 输入的 a 是不是 0

     首先将 c 赋值为 0

     用  a.equals(c)    判断 a 是不是 0

3、清零

     ans=new BigInteger(”0“);

4、用  ans=ans.add(b);  // 来计算 ans+ b 的值

AC CODE:

import java.util.*;
import java.math.*;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String args[])
	{
		Scanner cin = new Scanner(System.in);
		BigInteger a;
		BigInteger ans;
		BigInteger c=BigInteger.valueOf(0);
		ans=new BigInteger("0");
		while(cin.hasNext())
		{
			a=cin.nextBigInteger();
			if(a.equals(c))
				break;
			else {
				ans=ans.add(a);
			}
		}
		System.out.println(ans);
		
	}
}

I - Product

The problem is to multiply two integers X, Y . (0 ≤ X, Y < 10250)

Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12

12

2

222222222222222222222222

Sample Output

144

444444444444444444444444

本题是实现 大数的乘法乘法运算:

用到的是  ans=a.multiply(b);  //  算 a*b 

import java.util.*;
import java.math.*;


public class Main {
	public static void main(String args[])
	{
		Scanner cin = new Scanner(System.in);
		BigInteger a,b;
		BigInteger ans;
		BigInteger c=BigInteger.valueOf(0);
		ans=new BigInteger("0");
		while(cin.hasNext())
		{
			ans=new BigInteger("0");
			a=cin.nextBigInteger();
			b=cin.nextBigInteger();
			ans=a.multiply(b);
			System.out.println(ans);
		}
		
		
	}
}

猜你喜欢

转载自blog.csdn.net/JKdd123456/article/details/81173331