UVa 1583 Digit Generator 生成元 题解

英文

Description

For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M
is the digitsum of N, we call N a generator of M.
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of
256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one
generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case takes one line containing an integer N,
1 ≤ N ≤ 100, 000.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to
contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does
not have any generators, print ‘0’.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

中文

题目大意:

如果x加上x的各个数字之和得到y,就说x是y的生成元。给出n(1<=n<=100000),求最小生成元。无解输出0 。例如,n=216,121,2005时的解分别为198,0,1979 。

提示:

只要枚举就行了。但单纯的枚举容易炸,比如j要从n-45开始,不要从1开始,会快很多。f1是用来求数字和的。代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
int T,n;
bool bo;
int f1(int k)
{
    int ret=0;
    while(k>0)
    {
        ret+=k%10;
        k/=10;
    }
    return ret;
}
int main() 
{
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        bo=0;
        scanf("%d",&n);
        for(int j=n-45;j<=n;j++) if(f1(j)+j==n)
        {
            bo=1;
            printf("%d\n",j);
            break;
        }
        if(bo==0) printf("0\n");
    }
    return 0;
}

相关链接:

UVa题解小全:
https://blog.csdn.net/zj_mrz/article/details/81144019

UVa 1585 Score 得分 题解:
https://blog.csdn.net/zj_mrz/article/details/81144159

UVa 1586 Molar mass 分子量 题解:
https://blog.csdn.net/zj_mrz/article/details/81165988

XJOI 1327 The union set 区间合并 题解:
https://blog.csdn.net/zj_mrz/article/details/81043138

XJOI 3287 离散化 题解:
https://blog.csdn.net/zj_mrz/article/details/81037239

猜你喜欢

转载自blog.csdn.net/zj_mrz/article/details/81143855