【STL + 模拟】The Blocks Problem UVA - 101 【紫书例题】

【STL】The Blocks Problem UVA - 101 【紫书例题】

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies.
For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands.
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n − 1) with block bi adjacent to block bi+1 for all 0 ≤ i < n − 1 as shown in the diagram below:

这里写图片描述

The valid commands for the robot arm that manipulates blocks are:
• move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are
stacked on top of blocks a and b to their initial positions.
• move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after
returning any blocks that are stacked on top of block a to their initial positions.
• pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks
that are stacked above block a, onto block b. All blocks on top of block b are moved to their
initial positions prior to the pile taking place. The blocks stacked above block a retain their order
when moved.
• pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks
that are stacked above block a, onto the top of the stack containing block b. The blocks stacked
above block a retain their original order when moved.
• quit
terminates manipulations in the block world.
Any command in which a = b or in which a and b are in the same stack of blocks is an illegal
command. All illegal commands should be ignored and should have no affect on the configuration of
blocks.

Input
The input begins with an integer n on a line by itself representing the number of blocks in the block
world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your
program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically
incorrect commands.

Output
The output should consist of the final state of the blocks world. Each original block position numbered
i (0 ≤ i < n where n is the number of blocks) should appear followed immediately by a colon. If there
is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear
stacked in that position with each block number separated from other block numbers by a space. Don’t
put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the
integer on the first line of input).

Sample Input
10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output
0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:

题意:
这里写图片描述

move 把a块上面清空
onto 把b块上面清空
用vector模拟这里的0 — n-1个位置,总共只有两个操作:把某一个块a上面的块全部清空归位;把a及其上面的块,一起移动到b块的顶端。
在清除和移动的过程中,都需要先查找这个块现在在哪一个位置,在多高。
综上,总共需要3个函数:查找,清除,移动。

vector中resize函数是用来改变容器大小的。

AC代码:

#include <iostream>
#include <stdio.h>
#include <vector>

using namespace std;

const int maxn = 30;
int n, a, b;
string s1, s2;
vector<int> v[maxn];

void find_v(int a, int & p, int & h)
{
    for(p = 0; p < n; p++)
        for(h = 0; h < v[p].size(); h++)
        {
            if(v[p][h] == a)
                return ;
        }
}

void cl(int p, int h)
{
    for(int i = h + 1; i < v[p].size(); i++)
    {
        int cur = v[p][i];
        v[cur].push_back(cur);
    }
    v[p].resize(h + 1);
}

void mv(int p, int h, int pp)
{
    for(int i = h; i < v[p].size(); i++)
    {
        v[pp].push_back(v[p][i]);
    }
    v[p].resize(h);
}

void pt()
{
    for(int i = 0; i < n; i++)
    {
        printf("%d:", i);
        for(int j = 0; j < v[i].size(); j++)
        {
            printf(" %d", v[i][j]);
        }
        printf("\n");
    }
}

int main()
{
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
        v[i].push_back(i);
    while(cin >> s1)
    {
        if(s1 == "quit")
            break;
        cin >> a >> s2 >> b;
        int pa, pb, ha, hb;
        find_v(a, pa, ha);
        find_v(b, pb, hb);
        if(pa == pb)
            continue;
        if(s1 == "move")
            cl(pa, ha);
        if(s2 == "onto")
            cl(pb, hb);
        mv(pa, ha, pb);
    }
    pt();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/floraqiu/article/details/81209165