UVA - 514 Rails(栈)

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station
was built in last century. Unfortunately, funds were extremely limited that time. It was possible to
establish only a surface track. Moreover, it turned out that the station could be only a dead-end one
(see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction
B with coaches reorganized in some way. Assume that the train arriving from the direction A has
N ≤ 1000 coaches numbered in increasing order 1, 2, . . . , N. The chief for train reorganizations must
know whether it is possible to marshal coaches continuing in the direction B so that their order will
be a1.a2, . . . , aN . Help him and write a program that decides whether it is possible to get the required
order of coaches. You can assume that single coaches can be disconnected from the train before they
enter the station and that they can move themselves until they are on the track in the direction B. You
can also suppose that at any time there can be located as many coaches as necessary in the station.
But once a coach has entered the station it cannot return to the track in the direction A and also once
it has left the station in the direction B it cannot return back to the station.
Input
The input file consists of blocks of lines. Each block except the last describes one train and possibly
more requirements for its reorganization. In the first line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of 1, 2, . . . , N. The last line of the
block contains just ‘0’.
The last block consists of just one line containing ‘0’.
Output
The output file contains the lines corresponding to the lines with permutations in the input file. A line
of the output file contains ‘Yes’ if it is possible to marshal the coaches in the order required on the
corresponding line of the input file. Otherwise it contains ‘No’. In addition, there is one empty line after
the lines corresponding to one block of the input file. There is no line in the output file corresponding
to the last “null” block of the input file.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No
Yes

题意:铁轨按1-n的顺序从a进站,经过c中转站,问能否按给定顺序从b出站,后进先出,用栈

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
using namespace std;
typedef long long ll;

const int maxn = 1010;

int n,target[maxn];

int main()
{
    while(cin >>n && n){
        stack <int> s;
        while(1){
        while(!s.empty()) s.pop();
        int a = 1,b = 1;//a是进去的车厢号,b是出去的车厢数量
        for(int i = 1;i <= n;i++){
            cin >> target[i];//出去的车厢顺序
            if(!target[1]) break;
        }
        if(!target[1]){
            cout << endl;
            break;
        }
        int ok = 1;
        while(b <= n){//出去的车厢数量达到n,结束
            if(a == target[b]) a++,b++;//顺序输出,
            else if(!s.empty() && s.top()==target[b]) s.pop(),b++;//倒序输出
            else if(a <= n) s.push(a++);//存进栈里,注意条件,车厢号符合条件
            else {//找不到,这种顺序不行
                ok = 0;
                break;
            }
        }
        cout << (ok?"Yes":"No") << endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81219875