杭电1217

Arbitrage(难度:1)

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

思路:

(1)将货币视为结点,汇率视为权值,构造有向图;
(2)用map存储键值对;

  • 输入结点时,name[s]=i
  • 输入汇率时,u=name[s1],v=name[s2],change[u][v]=rate

(3)用Floyd算法求最短路径,算出最小权值,若权值大于1,则说明此种兑换方式获益,否则不获益。

扫描二维码关注公众号,回复: 2430311 查看本文章

AC代码:

#include <string.h>
#include <map>
#include <iostream>
using namespace std;
double change[35][35];
int n,m;

void floyed()
{
    int i,j,k;
    for(k=1;k<=n;k++)
    {
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(change[i][j]<change[i][k]*change[k][j])
                {
                    change[i][j]=change[i][k]*change[k][j];
                }
            }
        }
    }
}

int main()
{
    int i,j,icase=0;
    double rate;
    char s[100],s1[100],s2[100];
    while(cin>>n&&n!=0)
    {
        icase++;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(i==j) change[i][j]=1;
                else change[i][j]=0;
            }
        }
        map<string, int> name;
        for(i=1;i<=n;i++)
        {
            cin>>s;
            name[s] = i;
        }
        cin>>m;
        for(i=0;i<m;i++)
        {
            cin>>s1>>rate>>s2;
            int u=name[s1],v=name[s2];
            change[u][v]=rate;
        }

        floyed();

        bool flag=false;
        for(i=1;i<=n;i++)
        {
            if(change[i][i]>1)
            {
                flag=true;
                break;
            }
        }

        if(flag) cout<<"Case "<<icase<<": Yes"<<endl;
        else cout<<"Case "<<icase<<": No"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albert_bolt/article/details/81106652