kuangbin一B:POJ2251 Dungeon Master(BFS)

题目:
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.Is an escape possible? If yes, how long will it take?

Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.

Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

    Escaped in x minute(s). 


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

    Trapped! 

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

这道题是一道三维BFS的题目,主要就是复习一下BFS,以及一些构造的技巧。

#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <queue>
typedef long long ll;
using namespace std;

int l, r, c;
char dungeon[30][30][30];
int vis[30][30][30];
int ans;
int to[6][3] =    //把原本认为要手写的分枝写成表就可以用循环了,很好的技巧
{
    {0, 0, 1},
    {0, 0, -1},
    {0, 1, 0},
    {0, -1, 0},
    {1, 0, 0},
    {-1, 0, 0}
};

int l_st, r_st, c_st;
int l_ed, r_ed, c_ed;

struct pos{
    int L, R, C;
    int step;
};

int checkfalse(int lv, int rw, int cl)
{
    if(lv<0 || rw<0 || cl<0 || lv>=l || rw>=r || cl>=c)
        return 1;
    else if(dungeon[lv][rw][cl]=='#')
        return 1;
    else if(vis[lv][rw][cl])
        return 1;
    return 0;
}

int bfs()
{
    pos a, nxt;
    queue<pos> srch;
    a.L = l_st; a.R = r_st; a.C = c_st; a.step = 0;
    vis[l_st][r_st][c_st] = 1;
    srch.push(a);
    while(!srch.empty())
    {
        a = srch.front();
        srch.pop();
        if(a.L==l_ed && a.R==r_ed && a.C==c_ed)
            return a.step;
        for(int i = 0; i < 6; i++)
        {
            nxt = a;
            nxt.L = a.L + to[i][0];
            nxt.R = a.R + to[i][1];
            nxt.C = a.C + to[i][2];
            if(checkfalse(nxt.L, nxt.R, nxt.C))
                continue;
            vis[nxt.L][nxt.R][nxt.C] = 1;
            nxt.step = a.step + 1;
            srch.push(nxt);
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d %d %d", &l, &r, &c) && l+r+c)
    {
        ans = 0;
        getchar();
        memset(dungeon, 0, sizeof(dungeon));
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < l; i++)
        {
            for(int j = 0; j < r; j++)
            {
                scanf("%s", dungeon[i][j]);
                for(int k = 0; k < c; k++)
                {
                    if(dungeon[i][j][k]=='S')
                    {
                        l_st = i; r_st = j; c_st = k;
                    }
                    if(dungeon[i][j][k]=='E')
                    {
                        l_ed = i; r_ed = j; c_ed = k;
                    }
                }
            }
        }
        ans = bfs();
        if(ans)
            printf("Escaped in %d minute(s).\n", ans);
        else
            printf("Trapped!\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/izayoi_w/article/details/81162715