【PAT 甲级】1031 Hello World for U (20)

题目链接

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n~1~ characters, then left to right along the bottom line with n~2~ characters, and finally bottom-up along the vertical line with n~3~ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n~1~ = n~3~ = max { k| k <= n~2~ for all 3 <= n~2~ <= N } with n~1~

  • n~2~ + n~3~ - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

思路:题意说了左边长度n1=右边长度n3,而且n1<=n2,n2为一行字符的长度。而且n1+n2+n3-2=n。

所以可以得到n1=(n+2)/3,n2=n+2-n1*2。

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N = 1e5+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

int main() {
    char  str[N];
    cin>>str;
    int sz=strlen(str);
    int n1=(sz+2)/3,n2=sz-2*n1+2;
    for(int i=0; i<n1-1; i++) {
        cout<<str[i];
        for(int j=0; j<n2-2; j++) {
            cout<<" ";
        }
        cout<<str[sz-i-1];
        cout<<endl;
    }
    for(int i=n1-1; i<n1+n2-1; i++) {
        cout<<str[i];
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81174945
今日推荐