数据结构实验之链表四:有序链表的归并

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

#include <stdio.h>
#include <stdlib.h>

扫描二维码关注公众号,回复: 2507362 查看本文章

struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    struct node *head,*p,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    int i;
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return (head);
}
void display(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL) printf("%d\n",p->data);
        else printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    struct node *head1,*head2,*head3,*p,*q,*tail;
    int n,m;
    scanf("%d%d",&m,&n);
    head1=creat(m);
    head2=creat(n);
    head3=(struct node *)malloc(sizeof(struct node));
    head3->next=NULL;
    tail=head3;
    p=head1->next;
    q=head2->next;
    while(p!=NULL&&q!=NULL)
    {
        if(p->data<q->data)
        {
            tail->next=p;
            tail=p;
            p=p->next;
            tail->next=NULL;
        }
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
        }
    }
    if(p!=NULL)
    {
        tail->next=p;
    }
    else tail->next=q;
    display(head3);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/waitingac/article/details/81332610