C - Talented Chef

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most Mdifferent dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10

题意:要制作n样菜,制作第i样菜需要Ai个步骤,每分钟至多可以选择m样菜完成一个步骤,问至少需要多少时间

思路:刚开始,我的思路是选择步骤多的菜先完成的同时,按从大到小的顺序一一完成,可是转念一想是行不通的。所以,换个思路,假设全部都能恰好满足全部m个数字, if(sum%m == 0) k = sum / m ;
如果不能,我就多一次 if( sum%m!=0 ) k = sum / m +1;
但是还要和max比较。因为,这个数字至少是要>=max 的。
取大的那一个。

#include <iostream>
#include<stdio.h>
using namespace std;
int main()
{

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);

        int i;
        int ma=0,x,mun=0;
        for(i=0; i<n; i++)
        {
            scanf("%d",&x);
            mun+=x;
            if(ma<x)ma=x;
        }
        int k;
        if(mun%m==0)k=mun/m;
        else k=mun/m+1;
        if(k>ma)printf("%d\n",k);
        else printf("%d\n",ma);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81277901