hdu -- 2602

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 81948    Accepted Submission(s): 33895

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

14

Author Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1171 2191 

【分析】

  • 01背包问题
    #include<bits/stdc++.h>
    using namespace std;
    int v[1010],w[1010],dp[1010];
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            memset(dp,0,sizeof(dp));
            int n,m;
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;i++)
    		scanf("%d",&v[i]);
            for(int i=0;i<n;i++)
            	scanf("%d",&w[i]);
            for(int i=0;i<n;i++)
                for(int j=m;j>=w[i];j--)
                    dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            cout<<dp[m]<<endl;
        }
        return 0;
    }

猜你喜欢

转载自blog.csdn.net/qq_38735931/article/details/81268725