Apple Catching - poj2385 - dp

Apple Catching

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15024   Accepted: 7353

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

USACO 2004 November

思路:

定义dp,dp[i][j]表示第i分钟,转了j次得到的最大苹果数

第i分钟能得到的苹果数等于,在第i-1分钟时,不换树得到的苹果数和在第i-1分钟时换棵树得到的苹果数的最大值。

dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])

如果第i分钟所在的树恰好是落苹果的树,则dp[i][j]++

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<queue> 
#include<vector>

using namespace std;

int t,w;
int a[1005],dp[1005][35];
int main(){
	scanf("%d%d",&t,&w);
	for(int i=1;i<=t;i++){
		scanf("%d",&a[i]);
	}
	if(a[1]==1){
		dp[1][0]=1;
		dp[1][1]=0;
	}
	else{
		dp[1][0]=0;
		dp[1][1]=1;
	}
	
	for(int i=2;i<=t;i++){
		for(int j=0;j<=w;j++){
			if(j==0){
				dp[i][j]=dp[i-1][j]+a[i]%2;
			}
			else{
				dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]);
				if(j%2+1==a[i])dp[i][j]++;
			}
		}
	}
	
	int res=dp[t][0];
	for(int i=1;i<=w;i++){
		res=max(res,dp[t][i]);
	}
	printf("%d\n",res);
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81318722