Backward Digit Sums - poj3187 - 全排列

Backward Digit Sums

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9149   Accepted: 5206

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 
 

    3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

Source

USACO 2006 February Gold & Silver

思路:

用nest_permutation()函数进行全排列,然后判断。

注意:

要特判n=1哦~

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<set> 
#include<vector>

using namespace std;

int a[11],n,sum,b[11];

bool judge(){
    int tmp;
    for(int i=0;i<n-1;i++){
    	b[i]=a[i]+a[i+1];
	}
    for(int i=n-2;i>0;i--){
    	for(int j=0;j<i;j++){
    		b[j]+=b[j+1];
		}
	}
	if(b[0]==sum)return true;
	else return false;
}

int main(){
	scanf("%d%d",&n,&sum);
	for(int i=0;i<n;i++){
		a[i]=i+1;
	}
	if(n==1){
		printf("1\n");
		return 0;
	}
	do{
		if(judge()){
			for(int i=0;i<n-1;i++){
				printf("%d ",a[i]);
			}
			printf("%d\n",a[n-1]);
			return 0;
		}
	}while(next_permutation(a,a+n));
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81292204