2121 数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6
33 6 22 9 44 5

Sample Output

5 6 9 22 33 44

Hint

不得使用数组!

Source


#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node * next;
};
struct node *str (int n)
{
    int i;
    struct node *p,*head,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
};
struct node *pr(struct node *head,int n)
{
    int i,m;
    struct node *p,*q;

    for(i=0;i<n-1;i++)
    {
        p=head->next;
        q=p->next;
        while(p->next!=NULL)
        {
            if(p->data>q->data)
            {
                m=p->data;
                p->data=q->data;
                q->data=m;
            }
                p=p->next;
                q=q->next;
        }
    }
        return head;
};


void print (struct node *head)
{
    struct node *p;
    p=head->next;
    int s=0;
    while(p!=NULL)
    {
        if(s==0)
    {
        printf("%d",p->data);
        s=1;
    }
    else{

        printf(" %d",p->data);
    }
    p=p->next;
    }

    printf("\n");
}
int main()
{
    int n;
    struct node *h1,*t;
    scanf("%d",&n);
    h1=str(n);
    t=pr(h1,n);
    print(t);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81408239