pat-1001 A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

 题意:

  输出a+b,每三位用逗号分隔

思路:

  没什么难点,很多方法都可以做,这里我用一个比较简单的方法。

#include <string>
#include <iostream>
#include <sstream>
#include <cstdlib>
#include <cstdio>
using namespace std;
int main(){
    long a,b,c,i;
    while(cin>>a>>b){
        c=a+b;
        string str;
        str=to_string(c);//int 转换为string 类型

        size_t  len=str.length();
        if(c<0&&(len-1)%3==0){//这里考虑特殊情况,如:-100,000,负号后不用输出逗号
            for(i=(int)len-3;i>1;i-=3){//注意要从低位开始循环
                str.insert(i,",");
            }
        }
        else if(len%3==0){//这里考虑特殊情况,如100,000,最前面不用输出逗号
            for(i=(int)len-3;i>1;i-=3){
                str.insert(i,",");
            }
        }
        else{
            for(i=(int)len-3;i>0;i-=3){//这里考虑普通情况
                str.insert(i,",");
            }
        }

        cout<<str<<endl;
    }




    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/81382976
今日推荐