How Many Equations Can You Find

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3
21 1

Sample Output

18
1
#include<stdio.h>
#include<string.h>

const int maxn = 10000+10;
typedef long long ll; 

char s[maxn];
ll ans, len, n;

void DFS(int x, int y){
	if (y == len){
		if(x == n)
			ans ++;
		return ;
	}
	ll t = 0;
	for (int i = y; i < len; i++){
		t = t * 10 + (s[i]-'0');
		DFS(x+t, i+1);
		if (y != 0)
			DFS(x-t, i+1);
	}
}
/*
x是当前位置的和,y是当前位置的字符串长度
如果y == len, 意味着这是最后一个数字
判断此时位置的和是否与n相等。
t是当前位置之后截取的字符的值
每一次都遍历一次。
有一个条件就是y == 0的时候不能减 
*/ 
int main()
{
	while(scanf ("%s %lld", s, &n) != EOF){
		ans = 0;
		len = strlen(s); 
		DFS(0, 0);
		printf("%lld\n", ans);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hqzzbh/article/details/81347438
今日推荐