HDU 6319(单调队列)

传送门

题面:

Problem A. Ascending Rating

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 692    Accepted Submission(s): 184


 

Problem Description

Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant's QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m−1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=0 and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.

 

Input

The first line of the input contains an integer T(1≤T≤2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r,MOD≤109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,...,ak(0≤ai≤109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<i≤n) are then produced as follows :

ai=(p×ai−1+q×i+r)modMOD


It is guaranteed that ∑n≤7×107 and ∑k≤2×106.

 

扫描二维码关注公众号,回复: 2588407 查看本文章

Output

Since the output file may be very large, let's denote maxratingi and counti as the result of interval [i,i+m−1].
For each test case, you need to print a single line containing two integers A and B, where :

AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i)


Note that ``⊕'' denotes binary XOR operation.

Sample Input

1 10 6 10 5 5 5 5 3 2 2 1 5 7 6 8 2 9

Sample Output

46 11

题目描述:

    给定一个序列 a[1..n],对于每个长度为 m 的连续子区间, 求出区间 a 的最大值以及从左往右扫描该区间时 a 的最大值的 变化次数

题目分析:

    实际上这个题就是类似于poj2823的滑动窗口的问题。我们直接可以使用单调队列进行维护。(这个题目甚至比那道题更加容易,这道题只需要求区间最大值)。

    我们首先发现,如果我们正着做相对来说比较难处理,于是我们就考虑倒着做。

    我们只需从n枚举到1,在此过程中维护一个单调递减的单调队列即可。每当我们发现所取的区间范围在m内(即n-i+1>=m),我们就更新答案,其中不难发现,这个区间内的的最大值为单调队列的队尾元素,而这个区间内最大值更新的次数即为当前单调队列中队列的大小。

代码:

#include <bits/stdc++.h>
#define maxn 10000005
using namespace std;
typedef long long ll;
int a[maxn];
int n,m,k,p,q,r,mod;
int Q[maxn];
int head,tail;
ll res1,res2;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d%d%d%d%d",&n,&m,&k,&p,&q,&r,&mod);
        for(int i=1;i<=k;i++){
            scanf("%d",&a[i]);
        }
        for(int i=k+1;i<=n;i++){
            a[i]=(1ll*p*a[i-1]+1ll*q*i+r)%mod;
        }
        head=1,tail=0;
        res1=res2=0;
        for(int i=n;i>0;i--){
            while(tail>=head&&a[Q[tail]]<=a[i]) tail--;
            Q[++tail]=i;
            if(i+m-1<=n){
                while(Q[head]>=i+m) head++;
                res1+=i^a[Q[head]];
                res2+=i^(tail-head+1);
            }
        }
        printf("%lld %lld\n",res1,res2);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_39453270/article/details/81290616