uva 315 连通图求割点

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting

several places numbered by integers from 1 to

N

. No two places have the same number. The lines

are bidirectional and always connect together two places and in each place the lines end in a telephone

exchange. There is one telephone exchange in each place. From each place it is possible to reach

through lines every other place, however it need not be a direct connection, it can go through several

exchanges. From time to time the power supply fails at a place and then the exchange does not operate.

The officials from TLC realized that in such a case it can happen that besides the fact that the place

with the failure is unreachable, this can also cause that some other places cannot connect to each other.

In such a case we will say the place (where the failure occured) is critical. Now the officials are trying

to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line

of each block there is the number of places

N<

100

. Each of the next at most

N

lines contains the

number of a place followed by the numbers of some places to which there is a direct line from this place.

These at most

N

lines completely describe the network, i.e., each direct connection of two places in

the network is contained at least in one row. All numbers in one line are separated by one space. Each

block ends with a line containing just ‘

0

’. The last block has only one line with

N

= 0

.

Output

The output contains for each block except the last in the input file one line containing the number of

critical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

题目:https://vjudge.net/contest/229448#problem/B

题意:给你一个无向图,求其中割点的个数目。


//割点条件
//1.根节点有两个或两个以上节点
//2.其他节点u有一个子女v,low[v]>=dfn[u];
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;

const int maxn = 10005;
int low[maxn], dfn[maxn];
int father[maxn];
int cut[maxn];
int n, cnt;
vector<int> G[maxn];

void init()
{
    for(int i = 0; i < maxn; i++)
        G[i].clear();
    memset(low, 0, sizeof low);
    memset(dfn, 0, sizeof dfn);
    memset(father, 0, sizeof father);
    memset(cut, 0, sizeof cut);
    cnt = 0;
}

void Tarjan(int u,int fa)
{
    low[u] = dfn[u] = ++cnt;
    father[u] = fa;
    int len = G[u].size();
    for(int i = 0; i < len; i++)
    {
        int v = G[u][i];
        if(!dfn[v])
        {
            Tarjan(v, u);
            low[u] = min(low[u], low[v]);
        }
        else if(fa != v)
            low[u] = min(dfn[v], low[u]);
    }
}
void solve()
{
    int root = 0, ans = 0;
    Tarjan(1,0);

    for(int i = 2; i <= n; i++)
    {
        int v = father[i];
        if(v == 1)
            root ++; // 根节点子树 
        else if(dfn[v] <= low[i]) // 父亲节点的dfn 大于等于孩子的low 
            cut[v] = 1;
    }

    for(int i = 2; i <= n; i++)
    {
        if(cut[i])
            ans ++;
    }
    if(root > 1) // 根节点子树大于等于2 
        ans++;
    printf("%d\n", ans);
}

int main()
{
    while(~scanf("%d", &n) && n)
    {
        int a, b;
        char c;
        init();
        while(~scanf("%d", &a) && a)
        {
            while(~scanf("%d%c", &b, &c))
            {
                G[a].push_back(b);
                G[b].push_back(a);
                if(c == '\n')
                    break;
            }
        }
        solve();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38295645/article/details/81356514
315
今日推荐