D - Bridging signals

题目:

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 


A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4

题意:

先输入一个数t,表示有t组数据,每组数据第一行有一个p,下面紧接着p行,1<= i <=p,  每行的数字a[i]表示右边的 i 和左边的a[i]相连接,找出在不相交的情况下有多少相连的;

思路:

找一个最长上升子序列,看着p<=40000, 所以没有优化的求法肯定超时,所以呢,dp加上二分优化;

dp[i]=表示长度为i+1的上升子序列中的末尾元素最小值;

ps:


函数lower_bound()在first和last中的前闭后开区间进行二分查找,返回大于或等于val的第一个元素位置。
如果所有元素都小于val,则返回last的位置
举例如下:
一个数组number序列为:4,10,11,30,69,70,96,100.设要插入数字3,9,111.pos为要插入的位置的下标
 则:
pos = lower_bound( number, number + 8, 3) - number,pos = 0.即number数组的下标为0的位置。
pos = lower_bound( number, number + 8, 9) - number, pos = 1,即number数组的下标为1的位置(即10所在的位置)。
pos = lower_bound( number, number + 8, 111) - number, pos = 8,即number数组的下标为8的位置(但下标上限为7,
所以返回最后一个元素的下一个素)。
所以,要记住:函数lower_bound()在first和last中的前闭后开区间进行二分查找,返回大于或等于val的第一个元素位置。
如果所有元素都小于val,则返回last的位置,且last的位置是越界的!!~
返回查找元素的第一个可安插位置,也就是“元素值>=查找值”的第一个元素的位置

代码如下:

#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
const int INF=0x3f3f3f3f;
int a[40003],dp[40003];
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int i,j;
        int n;
        scanf("%d",&n);
        for(i=1; i<=n; i++)
            dp[i]=INF;
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(i=1; i<=n; i++)
        {
            *lower_bound(dp+1,dp+n+1,a[i])=a[i];
        }
        printf("%d\n",lower_bound(dp+1,dp+n+1,INF)-dp-1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81367364
今日推荐