【题解】HDU 1702 ACboy needs your help again!

目录

题目描述

题意分析

                                                                                                                   

题目描述

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT

Sample Output

1 2 2 1 1 2 None 2 3

题意分析

题意:FIFO 先进先出  FILO 先进后出  回想一下数据结构那么这便是一道十分简单的关于队列和栈操作的题了


#include <iostream>
#include <queue>
#include <stack>
#include <string>
using namespace std;

void handleq(int n)
{
    queue <int> q;
    string s;
    int m,i;
    for(i=0;i<n;i++)
    {
        cin>>s;
        if(s=="IN")
        {
            cin>>m;
            q.push(m);
        }
        else
        {
            if(q.empty())
            {
                cout<<"None"<<endl;
            }
            else
            {
                cout<<q.front()<<endl;
                q.pop();
            }
        }
    }
}

void handles(int n)
{
    stack <int> p;
    string s;
    int m,i;
    for(i=0;i<n;i++)
    {
        cin>>s;
        if(s=="IN")
        {
            cin>>m;
            p.push(m);
        }
        else
        {
            if(p.empty())
            {
                cout<<"None"<<endl;
            }
            else
            {
                cout<<p.top()<<endl;
                p.pop();
            }
        }
    }

}

int main()
{
    int t,n,i;
    string s;
    cin>>t;
    while(t--)
    {
        cin>>n;
        cin>>s;
        if(s=="FIFO")
        {
            handleq(n);
        }
        else
        {
            handles(n);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41220023/article/details/81358782
今日推荐