PAT 1001 A+B Format (20)

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

思路:

只是个控制输出格式而已,注意细节,其他就没什么啦。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

int main()
{
	int a, b;
	cin >> a >> b;
	a += b;
	string s1 = "", s2 = to_string(a);
	if (s2[0] == '-')
	{
		s1 += '-';
		s2 = s2.erase(0, 1);
	}
	if(s2.length()>3 && s2.length() % 3)
	{
		for (int i = 0; i < s2.length() % 3; i++)
			s1 += s2[i];
		s1 += ',';
		s2 = s2.erase(0, s2.length() % 3);
	}
	for (int i = 0; i < s2.length(); i++)
	{
		if (i != 0 && i % 3 == 0)
			s1 += ',';
		s1 += s2[i];
	}
	cout << s1 << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81544173