poj1651 区间DP

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

题目大意:给你一个算是数组串吧,有n个数,你需要从中拿出n-2个数,每拿出一个数就要有相应的的分数或者是费用,该费用的计算公式是:a[i-1]*a[i]*a[i+1],i是你所拿出的下标,其中第一个与最后一个是不能拿的,要使其和最小

扫描二维码关注公众号,回复: 2695481 查看本文章

区间上的问题,了解一下区间DP

#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long ll;
#define rep(i,a,b) for(int i=a;i<=b;i++)
const int MAXN=0x3f3f3f3f;
ll dp[105][105];
ll a[120];
int main(){

   int n;
   cin>>n;
 memset(dp,0,sizeof(dp));
   rep(i,1,n)
   cin>>a[i];
//   rep(i,1,n-2)
//   dp[i][i+2]=a[i]*a[i+1]*a[i+2];
   rep(len,3,n)//这里从第三位开始,因为前两位的计算是没有意义的
   {
       for(int i=1;i+len-1<=n;i++)
       {
           int j=len+i-1;
           dp[i][j]=MAXN;//一开始我是将其dp数组初始化为无穷大,对角线上的值为0,但是你在下一
           rep(k,i+1,j-1)//个for循环里面需要用到dp[1][2]的值为0,虽然它是原则上无意义的,但在  //                                                                            dp
           dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[i]*a[k]*a[j]);//的状态转移方程中
       }//却是需要的,如果全部为无穷大,就无法求出最小值,因此在这里就用哪个区间时,就令哪个区间
   }//为无穷大。
   cout<<dp[1][n]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/81485196