UVa 1586 Molar mass(模拟)

模拟思路:
有点像词法分析器里面的超前搜索
出现数字肯定之前是有元素的
如果出现了数字那么看它是两位数还是一位数
结合之前的化学元素算质量
默认元素个数为一
传送门
这里写图片描述
An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar
mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound
can be computed from the standard atomic weights of the elements.
When an organic compound is given as a molecular formula, Dr. CHON wants to nd its molar mass. A molecular formula, such as C3H4O3, identi es each constituent element by its chemical symbol and indicates the number of atoms of each
element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular ele-
ment, this quantity is indicated using a subscript after the chemical symbol. In this problem, we assume that the molecular formula is represented by only four elements, C'(Carbon),H’ (Hydrogen), O' (Oxygen), andN’ (Nitrogen) without parentheses.
The following table shows that the standard atomic weights for C',H’, O', andN’. Atomic Name Carbon Hydrogen Oxygen Nitrogen Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/mol For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6  (12.01 g/mol) + 6  (1.008 g/mol) + 1  (16.00 g/mol).
Given a molecular formula, write a program to compute the molar mass of the formula.
Input Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the rst line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the
chemical symbol would be omitted when the number is 1 (2  n  99).
Output
Your program is to write to standard output. Print exactly one line for each test case. The line should
contain the molar mass of the given molecular formula.
Sample Input
4
C
C6H5OH
NH2CH2COOH
C12H22O11
Sample Output
12.010
94.108
75.070
342.296
代码:

#include <stdio.h>
#include <string.h>
#include <ctype.h>
int main()
{
    int t;
    while(~scanf("%d",&t))
        while(t--)
        {
            float mass = 0.0,atom[26];
            atom['C'-'A'] = 12.01;
            atom['H'-'A'] = 1.008;
            atom['O'-'A'] = 16.00;
            atom['N'-'A'] = 14.01;
            char molecular[256];
            scanf("%s",molecular);
            for(int i=0; molecular[i]; i++)
            {
                int idx = 1;
                if(isdigit(molecular[i+1]))
                {
                    idx = molecular[i+1]-'0';
                    if(isdigit(molecular[i+2]))
                        idx = idx*10+molecular[i+2]-'0';
                }
                if(isalpha(molecular[i]))
                    mass+=atom[molecular[i]-'A']*idx;
            }
            printf("%.3f\n",mass);
        }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tilmant/article/details/81590688