PAT|1064. Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled,
with the possible exception of the bottom level, which is filled
from left to right.

Now given a sequence of distinct non-negative integer keys, a unique
BST can be constructed if it is required that the tree must also be a
CBT. You are supposed to output the level order traversal sequence of
this BST.

Input Specification:

Each input file contains one test case. For each case, the first line
contains a positive integer N (<=1000). Then N distinct non-negative
integer keys are given in the next line. All the numbers in a line are
separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal
sequence of the corresponding complete binary search tree. All the
numbers in a line must be separated by a space, and there must be no
extra space at the end of the line.

Sample Input: 10 1 2 3 4 5 6 7 8 9 0
Sample Output: 6 3 8 1 5 7 9 0 2 4

学习的别人的思路,完全二叉树左节点下标=root*2,右节点下标=root*2+1。

//#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int nodes[1001], tree[1001];
int pos, n;
bool cmp(int a,int b)
{
    return a < b;
}
void build(int root)
{
    if (root > n)
        return;
    int left = root * 2, right = root * 2 + 1;

    build(left);
    tree[root] = nodes[pos++];
    build(right);
}
int main()
{
    while (scanf("%d",&n)!=EOF)
    {
        int i;
        for (i = 0; i < n; i++)
            scanf("%d", &nodes[i]);
        sort(nodes, nodes + n, cmp);
        pos = 0;

        build(1);
        for (i = 1; i <= n; i++)
        {
            printf("%d%c", tree[i], n - i ? ' ' : '\n');
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_35205772/article/details/52450598