FatMouse and Cheese(记忆化搜索)

题目链接:https://vjudge.net/contest/245538#problem/L

 FatMouse and Cheese

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

这是一道记忆化搜索题,忽略了每次最多走m步的题意,也就是说,每次可以跨越最多m步所以在写方向的时候应该是乘上步数。

记忆化搜索的初级题目,写两三个小时,但是确实是自己写的。

#include<iostream>
#include<cstring>
using namespace std;
int n;
int m;
int vec[2000][2000];
int vis[2000][2000];
int dir[4][2]={ {1,0},{-1,0},{0,1},{0,-1}};
int ans=0;
int dfs(int i,int j){
	if(vis[i][j]!=-1){
		return vis[i][j]; 
	}
	int tt=0;
	for(int xx=1;xx<=m;xx++)
	for(int k=0;k<4;k++){
		int x=i+dir[k][0]*xx;
		int y=j+dir[k][1]*xx;
		if(x>=0 && x<n && y>=0 && y<n && vec[x][y]>vec[i][j]){
			tt=max(tt,dfs(x,y));
		}
	}
	vis[i][j]=tt+vec[i][j];
	return vis[i][j];
}
int main(){
	while(cin>>n>>m,n!=-1 && m!=-1){
		memset(vis,-1,sizeof(vis));
		memset(vec,0,sizeof(vec));
		ans=0;
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				cin>>vec[i][j];
			}
		}
		cout<<dfs(0,0)<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/guozuofeng/article/details/81565015
今日推荐