zoj4016用list去模拟栈

Given initially empty stacks, there are three types of operations:

  • 1 s v: Push the value onto the top of the -th stack.

  • 2 s: Pop the topmost value out of the -th stack, and print that value. If the -th stack is empty, pop nothing and print "EMPTY" (without quotes) instead.

  • 3 s t: Move every element in the -th stack onto the top of the -th stack in order.

    Precisely speaking, denote the original size of the -th stack by , and the original size of the -th stack by . Denote the original elements in the -th stack from bottom to top by , and the original elements in the -th stack from bottom to top by .

    After this operation, the -th stack is emptied, and the elements in the -th stack from bottom to top becomes . Of course, if , this operation actually does nothing.

There are operations in total. Please finish these operations in the input order and print the answer for every operation of the second type.


Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers and (), indicating the number of stacks and the number of operations.

The first integer of the following lines will be (), indicating the type of operation.

  • If , two integers and (, ) follow, indicating an operation of the first type.
  • If , one integer () follows, indicating an operation of the second type.
  • If , two integers and (, ) follow, indicating an operation of the third type.

It's guaranteed that neither the sum of nor the sum of over all test cases will exceed .

Output

For each operation of the second type output one line, indicating the answer.

Sample Input
2
2 15
1 1 10
1 1 11
1 2 12
1 2 13
3 1 2
1 2 14
2 1
2 1
2 1
2 1
2 1
3 2 1
2 2
2 2
2 2
3 7
3 1 2
3 1 3
3 2 1
2 1
2 2
2 3
2 3
Sample Output
13
12
11
10
EMPTY
14
EMPTY
EMPTY
EMPTY
EMPTY
EMPTY
EMPTY

如果当时我们很熟悉stl模板的话,就很轻易出了这道题了,注意最后一个元素必须用a.back()而不是输出a.end()

https://www.cnblogs.com/scandy-yuan/archive/2013/01/08/2851324.html 这是list详细应用

#include <iostream>
#include <cstdio>
#include <list>
using namespace std;
list<long long >a[300009];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,q,op,s,v,i,c;
        scanf("%d%d",&n,&q);
        for(i=1; i<=n; i++)
        {
            a[i].clear();
        }
        while(q--)
        {
            scanf("%d",&op);
            if(op==1)
            {
                scanf("%d%lld",&s,&v);
                a[s].push_back(v);
            }
            else if(op==2)
            {
                scanf("%d",&s);
                if(a[s].empty())
                {
                    printf("EMPTY\n");
                }
                else
                {
                    printf("%lld\n",a[s].back());
                    a[s].pop_back();
                }
            }
            else if(op==3)
            {
                scanf("%d%d",&s,&c);
                a[s].splice(a[s].end(),a[c]);
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/keepcoral/article/details/79963629
今日推荐