Find them, Catch them POJ - 1703 (并查集经典)

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;
const int MAXN = 1e5 + 5;
int f[2*MAXN];
int getf(int u)
{
	return f[u] == u ? u :f[u] = getf(f[u]);
}
bool merge(int u, int v)
{
	int t1 = getf(u);
	int t2 = getf(v);
	if (t1 == t2) return false;
	f[t2] = t1; return true;
}

int main(void) {
	int t;
	scanf("%d", &t);
	while (t--) {
		int n, m;
		scanf("%d %d", &n, &m);
		for (int i = 0; i <= 2*n + 5; ++i) f[i] = i;
		char p;
		int x, y;
		for (int i = 1; i <= m; ++i) {
			scanf(" %c %d %d", &p, &x, &y);
			if (p == 'A') {
				if(getf(x) == getf(y) || getf(x + n) == getf(y +n)) {
					printf("In the same gang.\n");
				} else if (getf(x) == getf(y + n) || getf(x + n) == getf(y)) {
					printf("In different gangs.\n");
				} else {
					printf("Not sure yet.\n");
				}
			} else {
				merge(x, y + n);
				merge(x + n, y);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/81149098
今日推荐