最长公共子序列 LCS (Longest Common Subsequence)

Common Subsequence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
#include<iostream>
#include<string.h>
using namespace std;
const int MAXN=1e4+5;
char a[MAXN];
char b[MAXN];
int dp[1000][1000];//不能开太大
int main()
{
    while(cin>>a>>b){
        memset(dp,0,sizeof(dp));
        for(int i=0;i<strlen(a);i++){
            for(int j=0;j<strlen(b);j++){
                if(a[i]==b[j])
                    dp[i+1][j+1]=dp[i][j]+1;
                else
                    dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
            }
        }
        cout<<dp[strlen(a)][strlen(b)]<<endl;
    }
    return 0;
}

发下帮助理解的代码 ,

#include<iostream>
#include<string.h>
using namespace std;
const int MAXN=1e4+5;
char a[MAXN];
char b[MAXN];
int dp[1000][1000];//不能开太大
int main()
{
    while(cin>>a>>b){
        memset(dp,0,sizeof(dp));
        for(int i=0;i<strlen(a);i++){
            for(int j=0;j<strlen(b);j++){
                if(a[i]==b[j]){//若两串当前元素相同
                    dp[i+1][j+1]=dp[i][j]+1;//则其当前LCS等于左上角LCS+1
                }
                else{//若两串当前元素不同,则其当前LCS一定等于左边,上边的LCS的最大值.
                    dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
                }
                cout<<dp[i+1][j+1]<<" ";//帮助理解
            }
            cout<<endl;//帮助理解
        }
        cout<<dp[strlen(a)][strlen(b)]<<endl;
    }
    return 0;
}
扫描二维码关注公众号,回复: 2723836 查看本文章

猜你喜欢

转载自blog.csdn.net/VP_Death_Note/article/details/81537116