HDU - 2602 Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

01背包问题,可以用一个一维数组改进空间复杂度

数据似乎出现了重量为0且有价值的骨头?

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAX = 1050;
int N, V;
int val[MAX];
int vol[MAX];

//dp[i][j]表示用1到i种骨头构成的最大重量为j的最大价值
int dp[MAX][MAX];
int DP[MAX];

int solve()
{
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= N; i++)
    {
        for (int j = 0; j <= V; j++)
        {
            if (j >= vol[i])
                dp[i][j] = max(dp[i-1][j], dp[i-1][j-vol[i]]+val[i]);
            else
                dp[i][j] = max(dp[i-1][j], dp[i][j]);
        }
    }

    memset(DP, 0, sizeof(DP));
    for (int i = 1; i <= N; i++)
    {
        for (int j = V; j >= vol[i]; j--)
            DP[j] = max(DP[j-vol[i]]+val[i], DP[j]);
    }

    return dp[N][V];
    //return DP[V];
}

int main()
{
    int T;
    cin >> T;

    while (T--)
    {
        cin >> N >> V;
        for (int i = 1; i <= N; i++)
            cin >> val[i];
        for (int i = 1; i <= N; i++)
            cin >> vol[i];
        cout << solve() << endl;
    }

    return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_39479426/article/details/81416947