eclipse各版本对应JDK版本要求

      最近换IDE前使用的idea,公司号召使用正版(付费)软件,然后又转回开源免费的Eclipse。

直接下载download页的版本(一般都是最新版),运行提示 need jdk1.8+ 。

郁闷。。。刚开始从官网的岛国镜像站还开vpn,却下载了挺长时间。。。

     提示一下:

不要使用默认镜像站

Download from: Japan - Yamagata University (http)

                                     File: eclipse-jee-mars-2-macosx-cocoa-x86_64.tar.gz SHA-512

切换一下,选择国内速度杠杠滴

现在mark一下,依据自己使用的 jdk版本 选择下载吧:

. Eclipse Neon (v4.6)---需要 JDK1.8+ 版本:(目前官网下载首选版)

----------------------------------------------------------------------------------------

Eclipse 4.6 (Neon)is scheduled for release on June 22, 2016.

A Java 8 JRE/JDK is required to run all Neon packages based on Eclipse 4.6. The reasoning behind requiring Java 8 are discussedhere.

2. Eclipse Mars (v4.5) ---需要 JDK1.7+ 版本:

----------------------------------------------------------------------------------------

Eclipse 4.5 (Mars) was released on June 24, 2015.

Consider using the new Installer! Please see 6 Steps to Install Eclipse.

A Java 7 JRE/JDK is required for all Mars package downloads based on Eclipse 4.5. Information concerning tested configurations for Eclipse 4.5 is providedhere.

3. Eclipse Luna (v4.4)  ---需要 JDK1.7+ 版本:

Eclipse 4.4 (Luna) was released on June 25, 2014.

A Java 7 JRE/JDK is required for most of the Luna package downloads based on Eclipse 4.4. Information concerning tested configurations for Eclipse 4.4 is providedhere.

4. Eclipse Kepler (v4.3) ---需要 JDK1.6+ 版本:

Eclipse 4.3 (Kepler) was released in June 2013.

A Java 6 JRE/JDK is recommended for Eclipse 4.3. More information concerning tested configurations for Eclipse 4.3 is providedhere.

查看链接: http://zl378837964.iteye.com/blog/2364145

猜你喜欢

转载自zl378837964.iteye.com/blog/2364145

相关文章