poj 2034 Anti-prime Sequences(素数筛选加dfs)

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

筛出素数后dfs

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,d,k,sum;
int ans[1010];
bool vis[1010];
bool isprime[10010];
void init()
{memset(isprime,1,sizeof(isprime));
isprime[0]=isprime[1]=0;
    for(int i=2;i<10010;i++)
    {if(isprime[i])
    for(int k=i*i;k<10010;k+=i)
    isprime[k]=0;
    }
}
bool ok(int pos,int num)
{int sum;
    if(pos==0)
    return true;
    int left=pos-d+1;
    if(left<0)
    left=0;
     sum=num;
    for(int i=pos-1;i>=left;i--)
    {sum+=ans[i];
        if(isprime[sum])
        return false;
    }
    return true;
}
void dfs(int pos)
{
    if(sum)
    return ;
    if(pos==m-n+1)
    {
        sum++;
        for(int i=0;i<m-n+1;i++)
        printf("%d%c",ans[i],(i==(m-n)?'\n':','));
        return ;
    }
    for(int i=n;i<=m;i++)
    {
        if(!vis[i]&&ok(pos,i))
        {vis[i]=1;
            ans[pos]=i;
            dfs(pos+1);
            vis[i]=0;
        }

    }
    return ;
}
int main()
{

    init();

    while(~scanf("%d%d%d",&n,&m,&d))
    {if(m+n+d==0)
    break;
        memset(vis,0,sizeof(vis));
    sum=0;
        dfs(0);
        if(sum==0)
        printf("No anti-prime sequence exists.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/81636292