PAT 乙级 1020 月饼(贪心+排序)

1020 月饼 (25)(25 分)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

分析:

贪心+排序。值得注意的是总售价和库存可能是小数。

C++:

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct good {
	double sumprice;
	double amount;
};
bool cmp(struct good a, struct good b)
{
	double uniprice1 = a.sumprice / a.amount;
	double uniprice2 = b.sumprice / b.amount;
	if (uniprice1 > uniprice2)
		return true;
	else
		return false;
}
int main()
{
	int kind,i=0;
	double sum=0,s,a,demand;
	scanf("%d %lf", &kind, &demand);
	vector<struct good>v(kind);
	for (int i = 0;i < kind;i++) {
		scanf("%lf", &a);
		v[i].amount = a;
	}
	for (int i = 0;i < kind;i++) {
		scanf("%lf",&s);
		v[i].sumprice = s;
	}
	sort(v.begin(), v.end(), cmp);
	while (demand > 0&&i<kind) {//从最贵的开始
		if (v[i].amount < demand)
			sum += v[i].sumprice;
		else 
			sum += (v[i].sumprice / v[i].amount)*demand;	
		demand -= v[i].amount;
		i++;
	}
	printf("%.2f", sum);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/81738677