poj 2236 并查集

A - Wireless Network

 
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
题目大意:
当前操作有两种,修复,跟判断是否连接;
用并查集将修复的电脑连接,并判断是否连接在一起。
#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 1010
using namespace std;
int d,use[maxn];
struct node
{
  int x,y,pre;
}a[maxn];
int find(int x)
{
    int r=x;
    while(r!=a[r].pre)
    {
        r=a[r].pre;
    }
    return r;
}
void join(node p1,node p2)
{
    int r1,r2;
    r1=find(p1.pre);
    r2=find(p2.pre);
    if(r1!=r2)
    {
        if((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y)<=d*d)
        a[r2].pre=r1;
    }
}
int main()
{
    int n;
    char s;
    scanf("%d%d",&n,&d);

        for(int i=1;i<=n;i++)
            a[i].pre=i;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
        }
        memset(use,0,sizeof(use));
        while(~scanf("\n%c",&s))
        {
            if(s==79)
            {
                int t;
              scanf("%d",&t);
              use[t]=1;
              for(int i=1;i<=n;i++)
              {
                  if(use[i]==1&&i!=t)
                  {
                      join(a[i],a[t]);
                  }
              }
            }
            else
            {
                int t1,t2;
                scanf("%d%d",&t1,&t2);
                if(find(t1)==find(t2))
                {
                    printf("SUCCESS\n");
                }
                else
                    printf("FAIL\n");
            }
        }

    return 0;
}











猜你喜欢

转载自blog.csdn.net/Black__wing/article/details/79210529