SDUt OJ数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N;
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6
33 6 22 9 44 5

Sample Output

5 6 9 22 33 44

Hint

不得使用数组!

Source

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
typedef struct st
{
    struct st *next;
    int data;
} tree;
void out(tree *h)
{
    tree *p;
    p=h->next;
    while(p)
    {
        if(p->next==NULL)printf("%d\n",p->data);
        else printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    tree *head,*p,*q,*tail;
    head=new tree;
    head->next=NULL;
    tail=head;
    int n;
    cin>>n;
    for(int i=0; i<n; i++)
    {
        p=new tree;
        cin>>p->data;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    int t;
    for( p=head->next; p; p=p->next)
    {
        for(q=p->next; q; q=q->next)
        {
            if(q->data<p->data)
            {
                t=q->data;
                q->data=p->data;
                p->data=t;
            }
        }
    }
    out(head);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81771816