2456:Aggressive cows

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

输出

* Line 1: One integer: the largest minimum distance

样例输入

5 3
1
2
8
4
9

样例输出

3

提示

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

来源

USACO 2005 February Gold

思路:通过二分法找距离,然后用函数测试一下距离是否符合,如果不符合减少长度,在判断;如果符合

增加长度看符不符合。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,c;
int a[100010];
bool judge(int d){
	int pre=0;
	for(int i=0;i<c;i++){
		int j=pre+1;
		while(j<n&&a[pre]+d>a[j]){
			j++;
		}
		if(j>=n) return false;
		pre=j;
	}
	return true;
}
bool check(int d){
	int cows=1,pre=0;
	for(int i=1;i<n;i++){
		if(a[pre]+d<=a[i]){
			pre=i;	
			cows++;
		}
	}
	if(cows>=c){
		return true;
	}else{
		return false;
	}
}
int main(){
	memset(a,0,sizeof(a));
	scanf("%d %d",&n,&c);
	for(int i=0;i<n;i++){
		scanf("%d",&a[i]);
	}
	sort(a,a+n);
	
	int save;
	int l=0;//
	int h=a[n-1]-a[0];//
	while(l<=h){
		int mid=l+(h-l)/2;
		if(check(mid)){
			save=mid;
			l=mid+1;
		}else{
			h=mid-1;
		}
	}
	cout<<save<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/aiLMengi000/article/details/81541252