K-th Number POJ - 2104 线段树 归并树

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

#include<vector>
#include<cstring>
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int M = 4e5+100;
int I[M],J[M],K[M];
vector<int>buck[M];
int A[M],nums[M];
int n,m;
int y11=0,y22=0;
void build(int k,int l,int r)
{
    if(r-l==1)
    {
        buck[k].push_back(A[l]);
     //   return ;
    }
    else
    {
        int mid=l+(r-l)/2;
        build(k<<1,l,mid);
        build(k<<1|1,mid,r);
        buck[k].resize(r-l);
        merge(buck[k<<1].begin(),buck[k<<1].end(),buck[k<<1|1].begin(),buck[k<<1|1].end(),buck[k].begin());
    }
}
int query(int k,int x,int l,int r)
{
    int res=0;
    if(y22<=l||r<=y11)
        return 0;
    if(l>=y11&&r<=y22)
    {
        res+=upper_bound(buck[k].begin(),buck[k].end(),x)-buck[k].begin();
    }
    else
    {
        int mid=l+(r-l)/2;
        res+=query(k<<1,x,l,mid);
        res+=query(k<<1|1,x,mid,r);
    }
    return res;
}
void solve()
{
    //建树
    build(1,0,n);
    for(int i=0;i<m;i++)
    {
        y11=I[i],y22=J[i]+1;
        int k=K[i];
        int lb=0,rb=n;
        while(rb>lb)
        {
            int mid=lb+(rb-lb)/2;
            int c=query(1,nums[mid],0,n);
            if(c>=k)
                rb=mid;
            else
                lb=mid+1;
        }
        printf("%d\n",nums[lb]);
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&A[i]);
        nums[i]=A[i];
    }
    sort(nums,nums+n);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&I[i],&J[i],&K[i]);
        I[i]--;
        J[i]--;
    }
    solve();
    return 0;
}


猜你喜欢

转载自blog.csdn.net/liluoyu_1016/article/details/79887208