Problem : [Usaco2006 Feb]Backward Digit Sums

Problem : [Usaco2006 Feb]Backward Digit Sums

Description
FJ and his cows enjoy playing a mental game. They write down the
numbers from 1 to N (1 <= N <= 10) in a certain order and then sum
adjacent numbers to produce a new list with one fewer number. They
repeat this until only a single number is left. For example, one
instance of the game (when N=4) might go like this:

3 1 2 4
4 3 6
7 9
16

Behind FJ’s back, the cows have started playing a more difficult
game, in which they try to determine the starting sequence from
only the final total and the number N. Unfortunately, the game is
a bit above FJ’s mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.
Input
* Line 1: Two space-separated integers: N and the final sum.
Output
* Line 1: An ordering of the integers 1..N that leads to the given
sum. If there are multiple solutions, choose the one that is
lexicographically least, i.e., that puts smaller numbers
first.
Sample Input
4 16
Sample Output
3 1 2 4
HINT
There are other possible sequences, such as 3 2 1 4, but 3 1 2 4

is the lexicographically smallest.

#include <bits/stdc++.h>
using namespace std;
int m,n;
int c[15];
int x[15];
int num[15],flag;
int find(int a, int num) {
    int i=1,ans=1;
    while(i<=a) {
        ans=ans*num/i;
        num--;
        i++;
    }
    return ans;
}
void dfs(int d,int val) {
    if(val>m)return;
    int i;
    if(d==n) {
        if(!flag&&val==m) {
            flag=1;
            printf("%d",num[0]);
            for(i=1;i<n;i++)
                printf(" %d",num[i]);
            return;
        }
    }
    for(i=1; i<=n&&!flag; i++) {
        if(!x[i]) {
            num[d]=i;
            x[i]=1;
            dfs(d+1,val+c[d]*i);
            x[i]=0;
        }
    }
}
int main() {
    cin>>n>>m;
    flag=0;
    for(int i=0; i<n; i++)
        c[i]=find(i,n-1);
    memset(vis,0,sizeof(vis));
    dfs(0,0);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41654438/article/details/81459568
今日推荐