UVA10935-卡片游戏

Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck: Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck. Your task is to find the sequence of discarded cards and the last, remaining card.

Input

Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed. Output

For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input

7 19 10 6 0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

//其实就是一个简单的队列的运用

#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
using namespace std;
queue<int> pai;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		{
			break;
		}
		
		for(int i=1;i<=n;i++)
		{
			pai.push(i);
		}
		int len=pai.size();
		if(len==1)
		{
			printf("Discarded cards:\n");
		}
		else
		{
			printf("Discarded cards:");
		}
		while(pai.size()-1)
		{
			if(pai.size()-1!=1)
			{
				printf(" %d,",pai.front());
			}
			else
			{
				printf(" %d\n",pai.front());
			}
			pai.pop();
			pai.push(pai.front());
			pai.pop();
		}
		printf("Remaining card:");
		printf(" %d\n",pai.front());
		pai.pop();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Jet_KILL/article/details/81257726
今日推荐