Prime Ring Problem(深搜

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66276    Accepted Submission(s): 28396


 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

 

6 8

 

Sample Output

 

Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

AC代码:

#include<cstdio>
#include<cstring>
int a[21],n,vis[21];

int su(int x)
{
	for(int i=2;i*i<=x;i++)
	if(x%i==0) return 0;
	return 1;
}

void dfs(int cur)
{
	if(cur==n&&su(a[0]+a[n-1]))
	{
		printf("%d",a[0]);
		for(int i=1;i<n;i++)
		printf(" %d",a[i]);
		printf("\n");
	}
	else 
	{
		for(int i=2;i<=n;i++)
		{
			if(!vis[i]&&su(i+a[cur-1]))
			{
				a[cur]=i;
				vis[i]=1;
				dfs(cur+1);
				vis[i]=0;
			}
		}
	}
	
}


int main()
{
	int t=1;
	a[0]=1;
	while(~scanf("%d",&n))
	{
		memset(vis,0,sizeof(vis));
		printf("Case %d:\n",t);
		t++;
		dfs(1);
		printf("\n");
	}
}

 

猜你喜欢

转载自blog.csdn.net/qq_42709126/article/details/81810996
今日推荐