PAT Advanced Level 1090

1090 Highest Price in Supply Chain(25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (105​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si​​ is the index of the supplier for the i-th member. Sroot​​ for the root supplier is defined to be 1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2
这是我两小时完成三道25分的题的第一题。最后只得了17分,竟然有段错误。我开了一个结构体,就本题来讲,的确是很多余,
出于习惯我就没改,以为出不了错,没想到真错这了。一看题解,又一拍大腿!!!我怎么没想到!!!AC代码如下:

/**********************
author: yomi
date: 18.8.20
ps:
**********************/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 101010;
vector<int>child[maxn];
bool vis[maxn];
int n, d, depth = 1, num, maxdepth;
double p, r, ans = 0.0;
int cmp(int a, int b)
{
    return a>b;
}
void dfs(int index, int depth)
{
    if(child[index].size() == 0){
        ans = max(ans, p);
        if(depth > maxdepth){
            maxdepth = depth;
            num=1;
        }
        else if(depth == maxdepth){
            num++;
        }
        return;
    }
    vis[index] = true;
    for(int i=0; i<child[index].size(); i++){
        if(!vis[child[index][i]]){

            p = p*(r/100.0+1);
            dfs(child[index][i], depth+1);

            p = p/(r/100.0+1);

        }
    }

}
int main()
{
    memset(vis, false, sizeof(vis));
    scanf("%d%lf%lf", &n, &p, &r);
    int k = 0;
    for(int i=0; i<n; i++){
        scanf("%d", &d);
        if(d == -1)
        {
            k = i;
            continue;
        }
        child[d].push_back(i);
    }
    dfs(k, 1);
    printf("%.2f %d",ans, num);
    return 0;
}
/**
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2
**/

猜你喜欢

转载自www.cnblogs.com/AbsolutelyPerfect/p/9506267.html