UVA-1997:The Suspects

UVA-1997:The Suspects

来源:UVA

标签:并查集

参考资料:

相似题目:

题目

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). Once a member in a group is a suspect, all members in the group are suspects. However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

输入

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n ≤ 30000 and 0 ≤ m ≤ 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

输出

For each case, output the number of suspects in one line.

输入样例

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

输出样例

4
1
1

题目大意

现有一名感染者出现在学校,学校里共n人,从0开始编号,恰巧0号同学就是这名感染者。学校里共有m个社团,感染病毒在各个社团间传染,即如果社团中有感染者,那么整个社团的所有成员都被感染。计算学校里有多少人被感染。

解题思路

利用并查集思想。

参考代码

#include<stdio.h>
#define MAXN 30000
int leader[MAXN+5];
int group[MAXN+5];
int find(int x){
    if(leader[x]==x){
        return x;
    }
    return leader[x]=find(leader[x]);
}

void join(int x,int y){
    int fx=find(x),
        fy=find(y);
    leader[fx]=fy;
}

int main(){
    int n,m;
    int k;
    while(scanf("%d%d",&n,&m) && n){
        for(int i=0;i<n;i++){
            leader[i]=i;
        }

        for(int i=0;i<m;i++){
            scanf("%d",&k);
            for(int j=0;j<k;j++){
                scanf("%d",&group[j]);
                join(group[0],group[j]);
            }
        }

        int ans=0;
        int t=find(leader[0]);
        for(int i=0;i<n;i++){
            if(find(leader[i])==t){
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/81457602