HDU ACM1061——Rightmost Digit

Rightmost Digit

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

题目大意:求N^N的个位数。
因为个位只有0~9,所以在不断相乘中总会形成循环,找到周期即可。

#include<stdio.h>
int main()
{
    int n,a,c[1000],i,sum,b,j;
    while(scanf("%d",&n)!=EOF){
        for(i=0;i<n;i++){
            scanf("%d",&a);
            c[1]=b=a%10;            
            for(j=2;j<=a;j++){  /*进行a-1次相乘直至找到周期*/ 
                c[j]=c[j-1]*b%10;
                if(c[j]==c[1])break;    /*如果相同则找到周期,周期为j-1*/ 
            }
            if(a%(j-1)==0)printf("%d\n",c[j-1]);    /*按周期求个位数*/
                else printf("%d\n",c[a%(j-1)]);
        }
    }
    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/BarisGuo/article/details/82115978