#67 【Tarjan模板*3】The Cow Prom

版权声明:反正也没有人会转,下一个 https://blog.csdn.net/drtlstf/article/details/82120196

Description

The N (2 <= N <= 10,000) cows are so excited: it's prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round Dance. 

Only cows can perform the Round Dance which requires a set of ropes and a circular stock tank. To begin, the cows line up around a circular stock tank and number themselves in clockwise order consecutively from 1..N. Each cow faces the tank so she can see the other dancers. 

They then acquire a total of M (2 <= M <= 100,000) ropes all of which are distributed to the cows who hold them in their hooves. Each cow hopes to be given one or more ropes to hold in both her left and right hooves; some cows might be disappointed. 

For the Round Dance to succeed for any given cow (say, Bessie), the ropes that she holds must be configured just right. To know if Bessie's dance is successful, one must examine the set of cows holding the other ends of her ropes (if she has any), along with the cows holding the other ends of any ropes they hold, etc. When Bessie dances clockwise around the tank, she must instantly pull all the other cows in her group around clockwise, too. Likewise, 
if she dances the other way, she must instantly pull the entire group counterclockwise (anti-clockwise in British English). 

Of course, if the ropes are not properly distributed then a set of cows might not form a proper dance group and thus can not succeed at the Round Dance. One way this happens is when only one rope connects two cows. One cow could pull the other in one direction, but could not pull the other direction (since pushing ropes is well-known to be fruitless). Note that the cows must Dance in lock-step: a dangling cow (perhaps with just one rope) that is eventually pulled along disqualifies a group from properly performing the Round Dance since she is not immediately pulled into lockstep with the rest. 

Given the ropes and their distribution to cows, how many groups of cows can properly perform the Round Dance? Note that a set of ropes and cows might wrap many times around the stock tank.

Input

Line 1: Two space-separated integers: N and M 

Lines 2..M+1: Each line contains two space-separated integers A and B that describe a rope from cow A to cow B in the clockwise direction.

Output

Line 1: A single line with a single integer that is the number of groups successfully dancing the Round Dance.

Sample Input

5 4
2 4
3 5
1 2
4 1

Sample Output

1

HINT

Explanation of the sample: 

ASCII art for Round Dancing is challenging. Nevertheless, here is a representation of the cows around the stock tank: 

 

_1___

/**** \

5 /****** 2

/ /**TANK**|

\ \********/

\ \******/  3

\ 4____/  /

\_______/


Cows 1, 2, and 4 are properly connected and form a complete Round Dance group. Cows 3 and 5 don't have the second rope they'd need to be able to pull both ways, thus they can not properly perform the Round Dance.

题意:给一个有向图,求出其中包含点数多于1的强连通分量的个数。

代码:

#include <iostream>
#include <cstring>
#include <vector>

#define SIZE 10010

using namespace std;

vector<int> graph[SIZE];
int dfn[SIZE], low[SIZE], tot, dfstime, s[SIZE], top;
bool instack[SIZE];

void tarjan(int u) // 又是Tarjan模板
{
	int v, i, count = 0;
	
	s[++top] = u;
	instack[u] = true;
	dfn[u] = low[u] = ++dfstime;
	for (i = 0; i < graph[u].size(); ++i)
	{
		v = graph[u][i];
		if (dfn[v] == -1)
		{
			tarjan(v);
			low[u] = min(low[u], low[v]);
		}
		else if (instack[v])
		{
			low[u] = min(low[u], dfn[v]);
		}
	}
	if (low[u] == dfn[u])
	{
		do
		{
			v = s[top--];
			instack[v] = false;
			++count;
		} while (v != u);
		if (count > 1) // 注意这一点!count要大于1才能计数器加一
		{
			++tot;
		}
	}
	
	return;
}

int main(int argc, char** argv)
{
	int n, m, u, v, i;
	
	scanf("%d%d", &n, &m);
	while (m--) // 建图
	{
		scanf("%d%d", &u, &v);
		graph[u].push_back(v);
	}
	
	memset(dfn, -1, sizeof (dfn));
	for (i = 1; i <= n; ++i)
	{
		if (dfn[i] == -1)
		{
			tarjan(i);
		}
	}
	
	printf("%d", tot);
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/drtlstf/article/details/82120196