HDU - 6438 Buy and Resell

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Lngxling/article/details/82084830

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1303    Accepted Submission(s): 427


 

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

 

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

 

Sample Input

 

3 4 1 2 10 9 5 9 5 9 10 5 2 2 1

 

 

Sample Output

 

16 4 5 2 0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

题意:

给定n个商店,每个商店都卖同样的一种东西,当从左到右依次经过每个商店时,可以选择以当前商店的价格买东西,卖东西,或者什么都不做,问最多能赚多少钱。

思路:

贪心,在每个位置处贪心寻找之前的可以购买的物品中价格最低的,用map维护一下已经卖出过的价格,当现在买入的价格之前被卖出过,就可以减少购买次数

#include <bits/stdc++.h>
using namespace std;
#define ll long long
priority_queue< ll,vector<ll>,greater<ll> >q;
map<ll,int>mp;
int n;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		while(!q.empty())
		q.pop();
		mp.clear();
		scanf("%d",&n);
		ll sum=0;
		int cnt=0;
		for(int i=1;i<=n;i++)
		{
			ll x;
			scanf("%lld",&x);
			if(!q.empty()&&x>q.top())
			{
				ll tp=q.top();
				q.pop();
				sum+=x-tp;
				mp[x]++;
				if(mp[tp]==0)
				{
					cnt++;
					q.push(x);
				}
				else
				{
					mp[tp]--;
					q.push(tp);
					q.push(x);
				}
			}
			else
			{
				q.push(x);
			}
		}
		printf("%lld %d\n",sum,cnt*2);
	}
}

猜你喜欢

转载自blog.csdn.net/Lngxling/article/details/82084830